summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-19 15:07:51 +0200
committermakefu <github@syntax-fehler.de>2017-09-19 15:07:51 +0200
commit95c63f06bf364f3b62fa0a99297c2000db61c81f (patch)
tree29a94343d6c8824453f35a4405993ee5c75c23f9 /setup.py
parentd94997cb359e0aba9d059f2538fba29c52407b05 (diff)
init
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..82f2262
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+from setuptools import setup, find_packages
+setup(
+ name='europastats',
+ version='0.1',
+ description='Convert stats websites to influx data',
+ author='Felix Richter',
+ license='WTFPL',
+ author_email='github@syntax-fehler.de',
+ url='https://github.com/makefu/europastats',
+ install_requires = [
+ 'requests',
+ 'docopt',
+ ],
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ "europastats": [
+ "data/*.json",
+ ],
+ },
+ entry_points = {
+ 'console_scripts': [
+ 'europa-attractions=europastats.attractions:main',
+ 'europa-weather=europastats.weather:main'
+ ],
+ },
+
+ keywords=['api'],
+)