summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..c6c970d
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,15 @@
+with import <nixpkgs> {};
+
+with pkgs.python3Packages;
+buildPythonPackage {
+ name = "python-env";
+ buildInputs = [
+ pytz
+ requests
+ docopt
+ paho-mqtt
+ influxdb
+ ];
+
+ src = ./.;
+}