summaryrefslogtreecommitdiffstats
path: root/tv/2configs/nginx-public_html.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/nginx-public_html.nix')
-rw-r--r--tv/2configs/nginx-public_html.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tv/2configs/nginx-public_html.nix b/tv/2configs/nginx-public_html.nix
new file mode 100644
index 000000000..50c623915
--- /dev/null
+++ b/tv/2configs/nginx-public_html.nix
@@ -0,0 +1,14 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ krebs.nginx = {
+ enable = true;
+ servers.default.locations = [
+ (nameValuePair "~ ^/~(.+?)(/.*)?\$" ''
+ alias /home/$1/public_html$2;
+ '')
+ ];
+ };
+}