summaryrefslogtreecommitdiffstats
path: root/tv/2configs/backup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/backup.nix')
-rw-r--r--tv/2configs/backup.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/tv/2configs/backup.nix b/tv/2configs/backup.nix
index 6c90709a8..641e2d586 100644
--- a/tv/2configs/backup.nix
+++ b/tv/2configs/backup.nix
@@ -1,5 +1,5 @@
{ config, lib, ... }:
-with lib;
+with config.krebs.lib;
{
krebs.backup.plans = {
wu-home-xu = {
@@ -26,5 +26,28 @@ with lib;
yearly = { format = "%Y"; };
};
};
+ } // mapAttrs (_: recursiveUpdate {
+ snapshots = {
+ minutely = { format = "%Y-%m-%dT%H:%M"; retain = 3; };
+ hourly = { format = "%Y-%m-%dT%H"; retain = 3; };
+ daily = { format = "%Y-%m-%d"; retain = 3; };
+ };
+ startAt = null;
+ }) {
+ xu-test-push-xu = {
+ method = "push";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.xu; path = "/bku/xu-test-push"; };
+ };
+ xu-test-pull-xu = {
+ method = "pull";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.xu; path = "/bku/xu-test-pull"; };
+ };
+ xu-test-push-wu = {
+ method = "push";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.wu; path = "/bku/xu-test-push"; };
+ };
};
}
[cgit] Unable to lock slot /tmp/cgit/82000000.lock: No such file or directory (2)