summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/broken/arduino-chroot
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/broken/arduino-chroot')
-rw-r--r--makefu/5pkgs/broken/arduino-chroot/default.nix20
-rw-r--r--makefu/5pkgs/broken/arduino-chroot/fhsUser.nix25
-rwxr-xr-xmakefu/5pkgs/broken/arduino-chroot/out/xtensa-lx106-elf-g++bin0 -> 685928 bytes
-rw-r--r--makefu/5pkgs/broken/arduino-chroot/xtensa-lx106-elf-g++.tar.gzbin0 -> 253935 bytes
4 files changed, 45 insertions, 0 deletions
diff --git a/makefu/5pkgs/broken/arduino-chroot/default.nix b/makefu/5pkgs/broken/arduino-chroot/default.nix
new file mode 100644
index 000000000..c08153dcf
--- /dev/null
+++ b/makefu/5pkgs/broken/arduino-chroot/default.nix
@@ -0,0 +1,20 @@
+{stdenv, pkgs, lib, ... }:
+
+stdenv.mkDerivation rec {
+ name = "xtensa-g++";
+ buildInputs = [ pkgs.makeWrapper ];
+
+ libPath = lib.makeLibraryPath [ pkgs.gcc.lib ];
+ src = ./xtensa-lx106-elf-g++.tar.gz;
+
+ phases = [ "unpackPhase" "installPhase" ];
+ installPhase = ''
+ set -x
+ mkdir -p $out/bin
+ cp ./xtensa-lx106-elf-g++ $out/bin/xtensa-lx106-elf-g++
+ patchelf \
+ --set-interpreter "$(< "$NIX_CC/nix-support/dynamic-linker")" \
+ --set-rpath "${libPath}" \
+ $out/bin/xtensa-lx106-elf-g++
+ '';
+}
diff --git a/makefu/5pkgs/broken/arduino-chroot/fhsUser.nix b/makefu/5pkgs/broken/arduino-chroot/fhsUser.nix
new file mode 100644
index 000000000..a699bbfb8
--- /dev/null
+++ b/makefu/5pkgs/broken/arduino-chroot/fhsUser.nix
@@ -0,0 +1,25 @@
+{ lib, pkgs, ... }: let
+
+env_nix = pkgs.writeText "env.nix" ''
+ { pkgs ? import <nixpkgs> {} }:
+
+ (pkgs.buildFHSUserEnv {
+ name = "simple-x11-env";
+ targetPkgs = pkgs: with pkgs; [
+ coreutils
+ gcc
+ arduino
+ ];
+ multiPkgs = pkgs: with pkgs; [
+ zlib
+ curl
+ ];
+ runScript = "arduino";
+ }).env
+'';
+
+
+in pkgs.writeDashBin "games-user-env" ''
+ nix-shell ${env_nix}
+''
+
diff --git a/makefu/5pkgs/broken/arduino-chroot/out/xtensa-lx106-elf-g++ b/makefu/5pkgs/broken/arduino-chroot/out/xtensa-lx106-elf-g++
new file mode 100755
index 000000000..745bb70ba
--- /dev/null
+++ b/makefu/5pkgs/broken/arduino-chroot/out/xtensa-lx106-elf-g++
Binary files differ
diff --git a/makefu/5pkgs/broken/arduino-chroot/xtensa-lx106-elf-g++.tar.gz b/makefu/5pkgs/broken/arduino-chroot/xtensa-lx106-elf-g++.tar.gz
new file mode 100644
index 000000000..1af7e2807
--- /dev/null
+++ b/makefu/5pkgs/broken/arduino-chroot/xtensa-lx106-elf-g++.tar.gz
Binary files differ