summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/smart-monitor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/smart-monitor.nix')
-rw-r--r--makefu/2configs/smart-monitor.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefu/2configs/smart-monitor.nix b/makefu/2configs/smart-monitor.nix
new file mode 100644
index 000000000..9b0290a9b
--- /dev/null
+++ b/makefu/2configs/smart-monitor.nix
@@ -0,0 +1,19 @@
+{ config, lib, ... }:
+{
+ krebs.exim-retiolum.enable = lib.mkDefault true;
+ services.smartd = {
+ enable = true;
+ notifications = {
+ mail = {
+ enable = true;
+ recipient = config.krebs.users.makefu.mail;
+ };
+ };
+ # short daily, long weekly, check on boot
+ defaults.monitored = "-a -o on -s (S/../.././02|L/../../7/04)";
+
+ devices = lib.mkDefault [{
+ device = "/dev/sda";
+ }];
+ };
+}