summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/x/config.nix')
-rw-r--r--makefu/1systems/x/config.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/makefu/1systems/x/config.nix b/makefu/1systems/x/config.nix
index 4c479875e..ea92e3485 100644
--- a/makefu/1systems/x/config.nix
+++ b/makefu/1systems/x/config.nix
@@ -162,7 +162,11 @@
krebs.tinc.retiolum.connectTo = [ "omo" "prism" "nextgum" "wbob" ];
# hard dependency because otherwise the device will not be unlocked
- boot.initrd.luks.devices = [ { name = "luksroot"; device = "/dev/sda2"; allowDiscards=true; }];
+ boot.initrd.luks.devices.luksroot =
+ {
+ device = "/dev/sda2";
+ allowDiscards = true;
+ };
# avoid full boot dir
boot.loader.grub.configurationLimit = 3;