summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wry.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/wry.nix')
-rw-r--r--makefu/1systems/wry.nix20
1 files changed, 13 insertions, 7 deletions
diff --git a/makefu/1systems/wry.nix b/makefu/1systems/wry.nix
index 6627d87b5..90710c857 100644
--- a/makefu/1systems/wry.nix
+++ b/makefu/1systems/wry.nix
@@ -8,9 +8,11 @@ let
in {
imports = [
# TODO: copy this config or move to krebs
- ../../tv/2configs/CAC-CentOS-7-64bit.nix
+ ../../tv/2configs/hw/CAC.nix
+ ../../tv/2configs/fs/CAC-CentOS-7-64bit.nix
../2configs/base.nix
../2configs/unstable-sources.nix
+ ../2configs/headless.nix
../2configs/tinc-basic-retiolum.nix
../2configs/bepasty-dual.nix
@@ -19,6 +21,13 @@ in {
# Reaktor
../2configs/Reaktor/simpleExtend.nix
+
+ # other nginx
+ ../2configs/nginx/euer.wiki.nix
+ ../2configs/nginx/euer.blog.nix
+
+ # collectd
+ ../2configs/collectd/collectd-base.nix
];
krebs.build = {
@@ -27,8 +36,6 @@ in {
host = config.krebs.hosts.wry;
};
-
-
krebs.Reaktor.enable = true;
# bepasty to listen only on the correct interfaces
@@ -47,7 +54,7 @@ in {
# TODO: remove hard-coded hostname
complete = {
listen = [ "${internal-ip}:80" ];
- server-names = [ "graphs.wry" ];
+ server-names = [ "graphs.wry" "graphs.retiolum" "graphs.wry.retiolum" ];
};
anonymous = {
listen = [ "${external-ip}:80" ] ;
@@ -58,6 +65,7 @@ in {
networking = {
firewall.allowPing = true;
firewall.allowedTCPPorts = [ 53 80 443 ];
+ firewall.allowedUDPPorts = [ 655 ];
interfaces.enp2s1.ip4 = [{
address = external-ip;
prefixLength = 24;
@@ -66,7 +74,5 @@ in {
nameservers = [ "8.8.8.8" ];
};
-
- # based on ../../tv/2configs/CAC-Developer-2.nix
- sound.enable = false;
+ environment.systemPackages = [ pkgs.translate-shell ];
}
[cgit] Unable to lock slot /tmp/cgit/70200000.lock: No such file or directory (2)