summaryrefslogtreecommitdiffstats
path: root/lass/2configs/weechat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/weechat.nix')
-rw-r--r--lass/2configs/weechat.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/lass/2configs/weechat.nix b/lass/2configs/weechat.nix
index 6a257f0bb..98f5df42a 100644
--- a/lass/2configs/weechat.nix
+++ b/lass/2configs/weechat.nix
@@ -1,14 +1,17 @@
{ config, lib, pkgs, ... }:
-{
- krebs.per-user.chat.packages = [
- pkgs.weechat
- pkgs.tmux
+let
+ inherit (config.krebs.lib) genid;
+in {
+ krebs.per-user.chat.packages = with pkgs; [
+ mosh
+ tmux
+ weechat
];
users.extraUsers.chat = {
home = "/home/chat";
- uid = lib.genid "chat";
+ uid = genid "chat";
useDefaultShell = true;
createHome = true;
openssh.authorizedKeys.keys = [
[cgit] Unable to lock slot /tmp/cgit/53000000.lock: No such file or directory (2)