summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/buildbot/slave.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/buildbot/slave.nix')
-rw-r--r--krebs/3modules/buildbot/slave.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/krebs/3modules/buildbot/slave.nix b/krebs/3modules/buildbot/slave.nix
index 932923ae5..345d4a3ea 100644
--- a/krebs/3modules/buildbot/slave.nix
+++ b/krebs/3modules/buildbot/slave.nix
@@ -2,12 +2,7 @@
with import <stockholm/lib>;
let
- nixpkgs-fix = import (pkgs.fetchgit {
- url = https://github.com/nixos/nixpkgs;
- rev = "e026b5c243ea39810826e68362718f5d703fb5d0";
- sha256 = "11lqd480bi6xbi7xbh4krrxmbp6a6iafv1d0q3sj461al0x0has8";
- }) {};
-
+ pkg = pkgs.buildbot-classic-slave;
buildbot-slave-init = pkgs.writeText "buildbot-slave.tac" ''
import os
@@ -158,7 +153,7 @@ let
workdir = shell.escape cfg.workDir;
contact = shell.escape cfg.contact;
description = shell.escape cfg.description;
- buildbot = nixpkgs-fix.buildbot-slave;
+ buildbot = pkg;
# TODO:make this
in {
PermissionsStartOnly = true;