summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple/fzmenu/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-28 22:19:52 +0100
committermakefu <github@syntax-fehler.de>2018-11-28 22:19:52 +0100
commitee4ffd2fcfd8c3906eb9bf4651c8a6fb70f6f3ea (patch)
tree82e9ff79db74ccc03f87c3c66972317ef3031a0d /tv/5pkgs/simple/fzmenu/default.nix
parent26c897d72ce24a300b871a737c74742f35221006 (diff)
parent95f6255f586e93e096d56de75add76d7560b9df1 (diff)
Merge remote-tracking branch 'lassul.us/master'
Diffstat (limited to 'tv/5pkgs/simple/fzmenu/default.nix')
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
new file mode 100644
index 000000000..c49c903c6
--- /dev/null
+++ b/tv/5pkgs/simple/fzmenu/default.nix
@@ -0,0 +1,34 @@
+{ coreutils, dash, gnused, fzf, pass, runCommand, rxvt_unicode, stdenv, utillinux, xdotool }:
+
+runCommand "fzmenu" {
+} /* sh */ ''
+ mkdir $out
+
+ cp -r ${./bin} $out/bin
+
+ substituteInPlace $out/bin/otpmenu \
+ --replace '#! /bin/sh' '#! ${dash}/bin/dash' \
+ --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ coreutils
+ dash
+ fzf
+ gnused
+ pass
+ rxvt_unicode
+ utillinux
+ xdotool
+ ]}
+
+ substituteInPlace $out/bin/passmenu \
+ --replace '#! /bin/sh' '#! ${dash}/bin/dash' \
+ --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ coreutils
+ dash
+ fzf
+ gnused
+ pass
+ rxvt_unicode
+ utillinux
+ xdotool
+ ]}
+''