summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sub/xr.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-11-07 19:24:46 +0100
committertv <tv@shackspace.de>2015-11-07 19:24:46 +0100
commita1c3f26b040ee1919c24491f4f3cb3a6e895fbce (patch)
tree5008ffe89bf2b2c7a7bf0e0c45ca984f9753dec4 /tv/2configs/sub/xr.nix
parentbbcdef021a9197ff4b6ae597600b649b9a7b998b (diff)
parente35e3b5eb05cea1e3c033423c2f6ee4e0a511817 (diff)
Merge remote-tracking branch 'nomic/master'
Diffstat (limited to 'tv/2configs/sub/xr.nix')
-rw-r--r--tv/2configs/sub/xr.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tv/2configs/sub/xr.nix b/tv/2configs/sub/xr.nix
new file mode 100644
index 000000000..6c9cbb93e
--- /dev/null
+++ b/tv/2configs/sub/xr.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ krebs.per-user.xr.packages = [
+ pkgs.cr
+ ];
+
+ security.sudo.extraConfig = "tv ALL=(xr) NOPASSWD: ALL";
+
+ users.users.xr = {
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ group = "subusers";
+ home = "/home/xr";
+ uid = 1660006127; # genid xr
+ useDefaultShell = true;
+ };
+}