summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/AO753.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-04 11:16:17 +0100
committermakefu <github@syntax-fehler.de>2016-02-04 11:16:17 +0100
commite89f43de944af3751b7a70de87e3cc0c1860f2bd (patch)
tree15401006a9cc87971f43d9c58e4e4ea5da522040 /tv/2configs/hw/AO753.nix
parentcc1a230fd2742b6ccadd0837d9cf569f246375aa (diff)
parent307e0afe851654e07e0c3fca25adf60ada3d974d (diff)
Merge 'cd/master' - update krebs.build.source
Diffstat (limited to 'tv/2configs/hw/AO753.nix')
-rw-r--r--tv/2configs/hw/AO753.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tv/2configs/hw/AO753.nix b/tv/2configs/hw/AO753.nix
index acd9ee32b..72a40819f 100644
--- a/tv/2configs/hw/AO753.nix
+++ b/tv/2configs/hw/AO753.nix
@@ -1,4 +1,6 @@
-{ config, pkgs, ... }:
+{ config, lib, pkgs, ... }:
+
+with lib;
{
imports = [
@@ -39,8 +41,5 @@
HandleSuspendKey=ignore
'';
- nixpkgs.config = {
- allowUnfree = false;
- allowUnfreePredicate = (x: pkgs.lib.hasPrefix "broadcom-sta-" x.name);
- };
+ nixpkgs.config.allowUnfreePredicate = pkg: hasPrefix "broadcom-sta-" pkg.name;
}