summaryrefslogtreecommitdiffstats
path: root/tv/2configs/git.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-24 13:16:35 +0200
committermakefu <github@syntax-fehler.de>2015-08-24 13:16:35 +0200
commitb25efb56e94d1b53d04af01320c697e3ad17b02c (patch)
treeaca65d4c638a822358214df811ab305be3c8983f /tv/2configs/git.nix
parent7c907ce6bc84e1d32f8041c96e4b0ca33c308bc4 (diff)
parentc73b2f6c175625f08d5898320ea8fcb336f393aa (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/2configs/git.nix')
-rw-r--r--tv/2configs/git.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/tv/2configs/git.nix b/tv/2configs/git.nix
index 8d662494c..264cb4a1c 100644
--- a/tv/2configs/git.nix
+++ b/tv/2configs/git.nix
@@ -8,14 +8,14 @@ let
enable = true;
root-title = "public repositories at ${config.krebs.build.host.name}";
root-desc = "keep calm and engage";
- inherit repos rules;
+ repos = mapAttrs (_: s: removeAttrs s ["collaborators"]) repos;
+ rules = rules;
};
};
- repos = mapAttrs (_: s: removeAttrs s ["collaborators"]) (
+ repos =
public-repos //
- optionalAttrs config.krebs.build.host.secure restricted-repos
- );
+ optionalAttrs config.krebs.build.host.secure restricted-repos;
rules = concatMap make-rules (attrValues repos);
@@ -66,8 +66,8 @@ let
};
};
- make-restricted-repo = name: { desc ? null, ... }: {
- inherit name desc;
+ make-restricted-repo = name: { collaborators ? [], desc ? null, ... }: {
+ inherit name collaborators desc;
public = false;
};