summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-09-04 20:53:12 +0200
committerlassulus <lass@blue.r>2018-09-04 20:53:12 +0200
commit96c4ab61202f515c7a361ef76c398e542771d6b4 (patch)
treece2ca90d0ae800bb3ba3e1b05593e7ba7bef104c /makefu/5pkgs/default.nix
parente183bb1c80c42131f9e3d932985e413ef457f77a (diff)
parent481376c1509661cbf1bdb17b9887b3a4f0487b6f (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/5pkgs/default.nix')
-rw-r--r--makefu/5pkgs/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/makefu/5pkgs/default.nix b/makefu/5pkgs/default.nix
index b1d6df67e..390c13ffe 100644
--- a/makefu/5pkgs/default.nix
+++ b/makefu/5pkgs/default.nix
@@ -1,6 +1,5 @@
-with import <stockholm/lib>;
-self: super: let
-
+self: super:
+with super.lib; with builtins; let
# This callPackage will try to detect obsolete overrides.
callPackage = path: args: let
override = super.callPackage path args;
@@ -15,6 +14,7 @@ self: super: let
override
else override;
+ eq = x: y: x == y;
subdirsOf = path:
mapAttrs (name: _: path + "/${name}")
(filterAttrs (_: eq "directory") (readDir path));
@@ -40,6 +40,6 @@ in {
};
}
-// mapAttrs (_: flip callPackage {})
+// (mapAttrs (_: flip callPackage {})
(filterAttrs (_: dir: pathExists (dir + "/default.nix"))
- (subdirsOf ./.))
+ (subdirsOf ./.)))