summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/vm-single-partition.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-07 12:53:02 +0200
committermakefu <github@syntax-fehler.de>2015-08-07 12:53:02 +0200
commit4d460eb95f398797df4d502be496a79481bdd809 (patch)
treeac7254fb32131fbd5be971639d6077c08db8d081 /makefu/2configs/vm-single-partition.nix
parent91a112c24294154be3b812e2b52e1c651d336aff (diff)
refactor pnp
Diffstat (limited to 'makefu/2configs/vm-single-partition.nix')
-rw-r--r--makefu/2configs/vm-single-partition.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/2configs/vm-single-partition.nix b/makefu/2configs/vm-single-partition.nix
new file mode 100644
index 000000000..78a5e7175
--- /dev/null
+++ b/makefu/2configs/vm-single-partition.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+
+}