summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/base-gui.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-07 12:10:02 +0200
committermakefu <github@syntax-fehler.de>2015-08-07 12:10:02 +0200
commit91a112c24294154be3b812e2b52e1c651d336aff (patch)
tree30548dd49faff0d82b60fda6eb8f3001e2d58266 /makefu/2configs/base-gui.nix
parenteeb7a84e988c0fa41113643505d2965b0f81ffb9 (diff)
refactor tsp
Diffstat (limited to 'makefu/2configs/base-gui.nix')
-rw-r--r--makefu/2configs/base-gui.nix26
1 files changed, 17 insertions, 9 deletions
diff --git a/makefu/2configs/base-gui.nix b/makefu/2configs/base-gui.nix
index 056005f75..7f329c6ce 100644
--- a/makefu/2configs/base-gui.nix
+++ b/makefu/2configs/base-gui.nix
@@ -1,31 +1,39 @@
{ config, lib, pkgs, ... }:
-
+##
+# of course this name is a lie - it prepares a GUI environment close to my
+# current configuration.
+#
+# autologin with mainUser into awesome
+##
+#
with lib;
+let
+ mainUser = config.krebs.build.user.name;
+in
{
imports = [ ];
services.xserver = {
enable = true;
layout = "us";
-# use awesome, direct boot into
- displayManager.auto.enable = true;
-# TODO: use config.krebs.users.makefu ... or not
- displayManager.auto.user = "makefu";
-
windowManager = {
awesome.enable = true;
awesome.luaModules = [ pkgs.luaPackages.vicious ];
default = "awesome";
};
+ displayManager.auto.enable = true;
+ displayManager.auto.user = mainUser;
desktopManager.xterm.enable = false;
- desktopManager.default = "none";
};
security.setuidPrograms = [ "slock" ];
-# use pulseaudio
- environment.systemPackages = [ pkgs.slock ];
+ environment.systemPackages = [
+ pkgs.slock
+ pkgs.rxvt_unicode-with-plugins
+ ];
+
hardware.pulseaudio = {
enable = true;
systemWide = true;
[cgit] Unable to lock slot /tmp/cgit/06100000.lock: No such file or directory (2)