summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/hw/omo.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-06-07 13:09:45 +0200
committerlassulus <lassulus@lassul.us>2020-06-07 13:09:45 +0200
commitfe119203ea4d2dc3e618d113c7f70629fd750aa3 (patch)
tree9b1b2e347e8fe66cacc9d93da7479100256332c9 /makefu/1systems/omo/hw/omo.nix
parent0f01f2899f68b8e142610994da529b5893f2a5f6 (diff)
parent360e823a9a187dd61d1c7f3f712a8edc9e7879d9 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/1systems/omo/hw/omo.nix')
-rw-r--r--makefu/1systems/omo/hw/omo.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/makefu/1systems/omo/hw/omo.nix b/makefu/1systems/omo/hw/omo.nix
index 87af2a314..586ad98c4 100644
--- a/makefu/1systems/omo/hw/omo.nix
+++ b/makefu/1systems/omo/hw/omo.nix
@@ -80,18 +80,19 @@ in {
boot = {
initrd.luks = {
devices = let
- usbkey = name: device: {
- inherit name device keyFile;
+ usbkey = device: {
+ inherit device keyFile;
keyFileSize = 4096;
allowDiscards = true;
};
- in [
- (usbkey "luksroot" rootPartition)
- (usbkey "crypt0" cryptDisk0)
- (usbkey "crypt1" cryptDisk1)
- (usbkey "crypt2" cryptDisk2)
- (usbkey "crypt3" cryptDisk3)
- ];
+ in
+ {
+ luksroot = usbkey rootPartition;
+ crypt0 = usbkey cryptDisk0;
+ crypt1 = usbkey cryptDisk1;
+ crypt2 = usbkey cryptDisk2;
+ crypt3 = usbkey cryptDisk3;
+ };
};
loader.grub.device = lib.mkForce rootDisk;