summaryrefslogtreecommitdiffstats
path: root/lass/2configs/steam.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-29 14:56:06 +0200
committermakefu <github@syntax-fehler.de>2015-07-29 14:56:06 +0200
commit0bf2b871dda30231443324588ab8142e125e9774 (patch)
tree0646d45eab135eb2c7d8665c31d7ac135e29afff /lass/2configs/steam.nix
parent671710c573980d859cb82993cd0514058a63262f (diff)
parent1bf670270c1e87900a908f7e9b949b5502158f4f (diff)
merge cloudkrebs, fix path to krebs/4lib
Diffstat (limited to 'lass/2configs/steam.nix')
-rw-r--r--lass/2configs/steam.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/lass/2configs/steam.nix b/lass/2configs/steam.nix
new file mode 100644
index 000000000..7d088fc6a
--- /dev/null
+++ b/lass/2configs/steam.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ nixpkgs.config.steam.java = true;
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}