summaryrefslogtreecommitdiffstats
path: root/lass/2configs/repo-sync.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-08 13:33:48 +0100
committermakefu <github@syntax-fehler.de>2017-12-08 13:33:48 +0100
commit3faa41106961e7a52e9400be23cdf10b64f4932c (patch)
treeccd6b4f1fea4b58484440da6f613ddbf55b3fe92 /lass/2configs/repo-sync.nix
parent04e6eeb7c8e2e3141293a84bc147265725208999 (diff)
parenta9b72bd2901ca232eb7b6523c535c593a36521ef (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/repo-sync.nix')
-rw-r--r--lass/2configs/repo-sync.nix25
1 files changed, 16 insertions, 9 deletions
diff --git a/lass/2configs/repo-sync.nix b/lass/2configs/repo-sync.nix
index f3ef23e67..98dbdc227 100644
--- a/lass/2configs/repo-sync.nix
+++ b/lass/2configs/repo-sync.nix
@@ -22,15 +22,22 @@ let
});
};
in {
- rules = with git; singleton {
- user = with config.krebs.users; [
- config.krebs.users."${config.networking.hostName}-repo-sync"
- lass
- lass-shodan
- ];
- repo = [ repo ];
- perm = push ''refs/*'' [ non-fast-forward create delete merge ];
- };
+ rules = with git; [
+ {
+ user = with config.krebs.users; [
+ config.krebs.users."${config.networking.hostName}-repo-sync"
+ lass
+ lass-shodan
+ ];
+ repo = [ repo ];
+ perm = push ''refs/*'' [ non-fast-forward create delete merge ];
+ }
+ {
+ user = attrValues config.krebs.users;
+ repo = [ repo ];
+ perm = fetch;
+ }
+ ];
repos."${name}" = repo;
};
[cgit] Unable to lock slot /tmp/cgit/2a300000.lock: No such file or directory (2)