summaryrefslogtreecommitdiffstats
path: root/lass/2configs/ppp.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-23 16:59:07 +0200
committermakefu <github@syntax-fehler.de>2020-04-23 16:59:07 +0200
commit07ab7b9519b6b5f253690101571f8fa12f20f4da (patch)
treeddb78a201c98177293c80135710b6c8b8e9025f2 /lass/2configs/ppp.nix
parent5b0d6c30d0bde6254d995a0c9b58b2ef70f16594 (diff)
parent0fbf9144d4bf93840faa49c7743e3273337bed0f (diff)
Merge remote-tracking branch 'lass/master' into 20.03
Diffstat (limited to 'lass/2configs/ppp.nix')
-rw-r--r--lass/2configs/ppp.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/lass/2configs/ppp.nix b/lass/2configs/ppp.nix
new file mode 100644
index 000000000..9cc7568a5
--- /dev/null
+++ b/lass/2configs/ppp.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }: {
+
+ # usage: pppd call default
+
+ environment.etc."ppp/peers/default".text = ''
+ /dev/ttyACM2
+ 921600
+ crtscts
+ defaultroute
+ holdoff 10
+ lock
+ maxfail 0
+ noauth
+ nodetach
+ noipdefault
+ passive
+ persist
+ usepeerdns
+ connect "${pkgs.ppp}/bin/chat -f ${pkgs.writeText "default.chat" ''
+ ABORT "BUSY"
+ ABORT "NO CARRIER"
+ REPORT CONNECT
+ "" "ATDT*99#"
+ CONNECT
+ ''}"
+ '';
+
+ environment.systemPackages = [
+ pkgs.ppp
+ ];
+
+}