summaryrefslogtreecommitdiffstats
path: root/lass/1systems/test-centos6.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
committermakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
commita1d05482e5527d32baef9d9343b900dee8d46694 (patch)
tree2de3ac509481799f6188620987cdf1678ea675a5 /lass/1systems/test-centos6.nix
parent709ebf6bbcc2e0d4644ed35cd42db47c4f2e78c5 (diff)
parent93dcfe5ad61903f90f422d9d6c97e499b240aa86 (diff)
Merge remote-tracking branch 'cloudkrebs/master'
Diffstat (limited to 'lass/1systems/test-centos6.nix')
-rw-r--r--lass/1systems/test-centos6.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/lass/1systems/test-centos6.nix b/lass/1systems/test-centos6.nix
new file mode 100644
index 000000000..7270c2262
--- /dev/null
+++ b/lass/1systems/test-centos6.nix
@@ -0,0 +1,30 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import ../4lib { inherit pkgs lib; }) getDefaultGateway;
+ inherit (lib) head;
+
+ ip = "168.235.148.52";
+in {
+ imports = [
+ ../2configs/base.nix
+ ../2configs/os-templates/CAC-CentOS-6.5-64bit.nix
+ {
+ networking.interfaces.enp11s0.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = getDefaultGateway ip;
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-centos6;
+}
[cgit] Unable to lock slot /tmp/cgit/22300000.lock: No such file or directory (2)