summaryrefslogtreecommitdiffstats
path: root/lass/1systems/shodan.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-10-24 14:14:58 +0200
committermakefu <github@syntax-fehler.de>2016-10-24 14:14:58 +0200
commit36cbb3d300eb18330a62ba20e35f80d515f5bc5f (patch)
treededf23acdc5763b59b5853b07dd297b88fb15636 /lass/1systems/shodan.nix
parent3fa63a4f312a885d353177db911f8a52ce7a1e1c (diff)
parent08c7671fc51270e582e16cbe49aa896f8bff7685 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'lass/1systems/shodan.nix')
-rw-r--r--lass/1systems/shodan.nix22
1 files changed, 21 insertions, 1 deletions
diff --git a/lass/1systems/shodan.nix b/lass/1systems/shodan.nix
index 5140591af..9d1df1d72 100644
--- a/lass/1systems/shodan.nix
+++ b/lass/1systems/shodan.nix
@@ -1,6 +1,6 @@
{ config, pkgs, ... }:
-with builtins;
+with import <stockholm/lib>;
{
imports = [
../.
@@ -22,6 +22,26 @@ with builtins;
# };
# };
#}
+ {
+ users.users.sokratess = {
+ uid = genid "sokratess";
+ home = "/home/sokratess";
+ group = "users";
+ createHome = true;
+ extraGroups = [
+ "audio"
+ "networkmanager"
+ ];
+ useDefaultShell = true;
+ password = "aidsballs";
+ };
+ krebs.per-user.sokratess.packages = [
+ pkgs.firefox
+ pkgs.python27Packages.virtualenv
+ pkgs.python27Packages.ipython
+ pkgs.python27Packages.python
+ ];
+ }
];
krebs.build.host = config.krebs.hosts.shodan;