summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/hashPassword/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-05 23:21:53 +0200
committermakefu <github@syntax-fehler.de>2018-04-05 23:21:53 +0200
commit54c104e1e1f59906ddf855d6993de14d07a093dc (patch)
treecc271ff3806fac4176997a1e51ef03b454e1a6e4 /krebs/5pkgs/simple/hashPassword/default.nix
parent241973f2ec1f4fcf217c37fd102feba82bc0b66e (diff)
parent1dd03483619d00d1afc6a278ded0cca6cff2d9ed (diff)
Merge remote-tracking branch 'lass/master' into stagingstaging
Diffstat (limited to 'krebs/5pkgs/simple/hashPassword/default.nix')
-rw-r--r--krebs/5pkgs/simple/hashPassword/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/krebs/5pkgs/simple/hashPassword/default.nix b/krebs/5pkgs/simple/hashPassword/default.nix
index 3da65ad79..3c604be80 100644
--- a/krebs/5pkgs/simple/hashPassword/default.nix
+++ b/krebs/5pkgs/simple/hashPassword/default.nix
@@ -1,7 +1,7 @@
{ lib, pkgs, ... }:
pkgs.writeDashBin "hashPassword" ''
- # usage: hashPassword
+ # usage: hashPassword [...]
set -euf
export PATH=${lib.makeBinPath (with pkgs; [
@@ -11,5 +11,5 @@ pkgs.writeDashBin "hashPassword" ''
])}
salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
- exec mkpasswd -m sha-512 -S "$salt"
+ exec mkpasswd -m sha-512 -S "$salt" "$@"
''