summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/lib.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-15 17:07:48 +0100
committermakefu <github@syntax-fehler.de>2016-02-15 17:07:48 +0100
commit3ceff0ec29a36119ea83f02c8943752d91b250e9 (patch)
tree7b179bc972ea01c9305ea64697e14237346885d8 /krebs/3modules/lib.nix
parent9a4071b66ff45e99a30e9a314eb43c6efc7e921f (diff)
parent372f2d77f301719e396a6f943657325e2f8b2cf4 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/3modules/lib.nix')
-rw-r--r--krebs/3modules/lib.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/3modules/lib.nix b/krebs/3modules/lib.nix
new file mode 100644
index 000000000..b19f275b5
--- /dev/null
+++ b/krebs/3modules/lib.nix
@@ -0,0 +1,15 @@
+{ config, pkgs, lib, ... }:
+with lib;
+let
+ out = {
+ options.krebs.lib = api;
+ config = imp;
+ };
+ api = mkOption {
+ default = {};
+ type = types.attrs;
+ };
+ imp = {
+ krebs.lib = lib // import ../4lib { inherit lib; } // builtins;
+ };
+in out
[cgit] Unable to lock slot /tmp/cgit/1d000000.lock: No such file or directory (2)