summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-03-31 22:35:53 +0200
committermakefu <github@syntax-fehler.de>2020-03-31 22:35:53 +0200
commitffef23f1854d8166eec75a5d94b2524a63e6e06c (patch)
tree7e141930e4a5b99e411cd10934170abdfda05cd0 /shell.nix
parente4942fdab9a43712d56b38dbdb8421d38d7743df (diff)
add sorted
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 4 insertions, 12 deletions
diff --git a/shell.nix b/shell.nix
index 79beb8a..a9bef78 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,16 +1,5 @@
-let
- # Look here for information about how to generate `nixpkgs-version.json`.
- # → https://nixos.wiki/wiki/FAQ/Pinning_Nixpkgs
- pinnedVersion = builtins.fromJSON (builtins.readFile ./.nixpkgs-version.json);
- pinnedPkgs = import (builtins.fetchGit {
- inherit (pinnedVersion) url rev;
-
- ref = "nixos-unstable";
- }) {};
-in
-
# This allows overriding pkgs by passing `--arg pkgs ...`
-{ pkgs ? pinnedPkgs }:
+{ pkgs ? (import <nixpkgs> {}).pkgs}:
with pkgs.python3.pkgs;
buildPythonPackage {
@@ -18,8 +7,11 @@ buildPythonPackage {
src = ./.;
propagatedBuildInputs = [
docopt
+ pyyaml
requests
beautifulsoup4
+ dateutil
+ feedgen
];
checkInputs = [ black jq ];
}