summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-03-11 09:22:58 +0100
committermakefu <github@syntax-fehler.de>2020-03-11 09:26:51 +0100
commit1ab0949f9d8e97aafafbd347a625fd97eeaa48a3 (patch)
treebafe9c821463eb71d7944a2d9cf85082a9c6481e /setup.py
parenta19ccf35dc0b01a509c88c8b66c79aa0d2a986b4 (diff)
init project setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e4a01da
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+from setuptools import setup
+
+setup(
+ name="ebknotify",
+ description="Notify on new ebay kleinanzeigen inputs",
+ version="1.0.0",
+ packages=["ebknotify"],
+ license="MIT",
+ long_description=open("README.md").read(),
+ author="Felix Richter",
+ author_email="github@krebsco.de",
+ install_requires=[
+ "requests",
+ "docopt"
+ ],
+ entry_points={"console_scripts": ["ebk-notify = ebknotify.cli:main"]},
+ classifiers=[
+ "Intended Audience :: Human",
+ "Natural Language :: English",
+ "Operating System :: POSIX :: Linux",
+ "Development Status :: 3 - Alpha",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+)