summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wbob.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/wbob.nix')
-rw-r--r--makefu/1systems/wbob.nix45
1 files changed, 27 insertions, 18 deletions
diff --git a/makefu/1systems/wbob.nix b/makefu/1systems/wbob.nix
index b4f7c9058..45b935af0 100644
--- a/makefu/1systems/wbob.nix
+++ b/makefu/1systems/wbob.nix
@@ -1,5 +1,10 @@
{ config, pkgs, ... }:
{
+ makefu.awesome = {
+ modkey = "Mod1";
+ #TODO: integrate kiosk config into full config by templating the autostart
+ baseConfig = pkgs.awesomecfg.kiosk;
+ };
imports =
[ # Include the results of the hardware scan.
../.
@@ -10,6 +15,15 @@
retiolum.enable = true;
build.host = config.krebs.hosts.wbob;
};
+ networking.firewall.allowedUDPPorts = [ 1655 ];
+ networking.firewall.allowedTCPPorts = [ 1655 ];
+ services.tinc.networks.siem = {
+ name = "display";
+ extraConfig = ''
+ ConnectTo = sjump
+ Port = 1655
+ '';
+ };
# rt2870.bin wifi card, part of linux-unfree
hardware.enableAllFirmware = true;
@@ -39,23 +53,18 @@
xrandr --output HDMI2 --right-of HDMI1
'';
};
- ## TODO Awesomecfg + autostart chrome
- #
- #local current_screen = 1
- #awful.rules.rules = {
- # { rule = { class = "chromium-browser" },
- # callback = function()
- # awful.client.movetotag(tags[current_screen][1],c)
- # if (current_screen == 1) then
- # current_screen = current_screen+1
- # else
- # current_screen = current_screen-1
- # end
- # end
- # },
- #}
- #awful.util.spawn_with_shell("chromium --new-window --kiosk http://wolf:3000/dashboard/db/soc-critical-values")
- # prevent Race Condition
- #awful.util.spawn_with_shell("sleep 0.5;chromium --new-window --kiosk http://wolf:3000/dashboard/db/aralast")
+ # TODO: update synergy package with these extras (username)
+ # TODO: add crypto layer
+ systemd.services."synergy-client" = {
+ environment.DISPLAY = ":0";
+ serviceConfig.User = "makefu";
+ };
+ services.synergy = {
+ client = {
+ enable = true;
+ screenName = "wbob";
+ serverAddress = "pornocauster.r";
+ };
+ };
}