summaryrefslogtreecommitdiffstats
path: root/lass/2configs/copyq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/copyq.nix')
-rw-r--r--lass/2configs/copyq.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/lass/2configs/copyq.nix b/lass/2configs/copyq.nix
index 0616c4025..b255254f2 100644
--- a/lass/2configs/copyq.nix
+++ b/lass/2configs/copyq.nix
@@ -9,7 +9,7 @@ let
${pkgs.copyq}/bin/copyq config activate_closes true
${pkgs.copyq}/bin/copyq config clipboard_notification_lines 0
- ${pkgs.copyq}/bin/copyq config clipboard_tab clipboard
+ ${pkgs.copyq}/bin/copyq config clipboard_tab \&clipboard
${pkgs.copyq}/bin/copyq config disable_tray true
${pkgs.copyq}/bin/copyq config hide_tabs true
${pkgs.copyq}/bin/copyq config hide_toolbar true
@@ -19,10 +19,9 @@ let
${pkgs.copyq}/bin/copyq config text_wrap true
'';
in {
- systemd.user.services.copyq = {
- after = [ "graphical.target" ];
- wants = [ "graphical.target" ];
- wantedBy = [ "default.target" ];
+ systemd.services.copyq = {
+ wantedBy = [ "multi-user.target" ];
+ requires = [ "display-manager.service" ];
environment = {
DISPLAY = ":0";
};
@@ -33,6 +32,7 @@ in {
Restart = "always";
RestartSec = "2s";
StartLimitBurst = 0;
+ User = "lass";
};
};
}