summaryrefslogtreecommitdiffstats
path: root/lass/1systems/green/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/green/config.nix')
-rw-r--r--lass/1systems/green/config.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/lass/1systems/green/config.nix b/lass/1systems/green/config.nix
index b41e396c9..5cf7d9242 100644
--- a/lass/1systems/green/config.nix
+++ b/lass/1systems/green/config.nix
@@ -42,13 +42,6 @@ with import <stockholm/lib>;
"-M ${toString config.users.users.mainUser.uid}"
];
};
- "/home/lass/sync" = {
- source = "/var/state/lass_sync";
- options = [
- "-M ${concatMapStringsSep ":" (u: toString config.users.users.${u}.uid) [ "syncthing" "mainUser" ]}"
- "--create-for-user=${toString config.users.users.syncthing.uid}"
- ];
- };
"/var/lib/bitlbee" = {
source = "/var/state/bitlbee";
options = [
@@ -94,4 +87,10 @@ with import <stockholm/lib>;
krebs.iptables.tables.nat.PREROUTING.rules = [
{ predicate = "-i eth0 -p tcp -m tcp --dport 22"; target = "ACCEPT"; precedence = 101; }
];
+
+ # workaround for ssh access from yubikey via android
+ services.openssh.extraConfig = ''
+ HostKeyAlgorithms +ssh-rsa
+ PubkeyAcceptedAlgorithms +ssh-rsa
+ '';
}
[cgit] Unable to lock slot /tmp/cgit/c8300000.lock: No such file or directory (2)