summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/urlwatch/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/urlwatch/default.nix')
-rw-r--r--krebs/5pkgs/urlwatch/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/krebs/5pkgs/urlwatch/default.nix b/krebs/5pkgs/urlwatch/default.nix
index 780ad24f5..ae1416204 100644
--- a/krebs/5pkgs/urlwatch/default.nix
+++ b/krebs/5pkgs/urlwatch/default.nix
@@ -1,11 +1,11 @@
{ stdenv, fetchurl, python3Packages }:
python3Packages.buildPythonPackage rec {
- name = "urlwatch-2.1";
+ name = "urlwatch-2.2";
src = fetchurl {
url = "https://thp.io/2008/urlwatch/${name}.tar.gz";
- sha256 = "0xn435cml9wjwk39117p1diqmvw3jbmv9ccr7230iaf7z59vf9v6";
+ sha256 = "0s9056mm1hkj5gpzsb5bz6fwxk0nm73i0dhnqwa1bfddjnvpl9d3";
};
propagatedBuildInputs = with python3Packages; [
@@ -15,6 +15,10 @@ python3Packages.buildPythonPackage rec {
requests2
];
+ patches = [
+ ./setup.patch
+ ];
+
postFixup = ''
wrapProgram "$out/bin/urlwatch" --prefix "PYTHONPATH" : "$PYTHONPATH"
'';