summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index dff071852..668f956a4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -43,8 +43,9 @@
(lib.attrNames (builtins.readDir ./3modules))));
overlays.default = import ./5pkgs/default.nix;
- nixosConfigurations = lib.genAttrs ["x" "tsp" "wbob" "omo" "gum"] (host: nixpkgs.lib.nixosSystem rec {
- system = "x86_64-linux";
+ nixosConfigurations = lib.genAttrs ["x" "cake" "tsp" "wbob" "omo" "gum"] (host: nixpkgs.lib.nixosSystem rec {
+ # TODO inject the system somewhere else
+ system = if host == "cake" then "aarch64-linux" else "x86_64-linux";
specialArgs = {
inherit (inputs) nixos-hardware self stockholm nixpkgs;
pkgs = import nixpkgs {