summaryrefslogtreecommitdiffstats
path: root/2configs/fs/disko/single-disk-encrypted-zfs.nix
diff options
context:
space:
mode:
Diffstat (limited to '2configs/fs/disko/single-disk-encrypted-zfs.nix')
-rw-r--r--2configs/fs/disko/single-disk-encrypted-zfs.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/2configs/fs/disko/single-disk-encrypted-zfs.nix b/2configs/fs/disko/single-disk-encrypted-zfs.nix
index 1b35e5b2b..9454c9892 100644
--- a/2configs/fs/disko/single-disk-encrypted-zfs.nix
+++ b/2configs/fs/disko/single-disk-encrypted-zfs.nix
@@ -1,8 +1,13 @@
-{ disks ? [ "/dev/nvme0n1" ], ... }:
+{ disks ? [ "/dev/nvme0n1" ], hostId, ... }:
let
disk = builtins.elemAt disks 0;
in {
+ boot.zfs.requestEncryptionCredentials = true;
boot.supportedFilesystems = [ "zfs" ];
+ boot.loader.efi.canTouchEfiVariables = true;
+ boot.loader.systemd-boot.enable = true;
+ networking.hostId = hostId;
+
disko.devices = {
disk = {
nvme = {