summaryrefslogtreecommitdiffstats
path: root/2configs/fs/disko/single-disk-bcachefs.nix
diff options
context:
space:
mode:
Diffstat (limited to '2configs/fs/disko/single-disk-bcachefs.nix')
-rw-r--r--2configs/fs/disko/single-disk-bcachefs.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/2configs/fs/disko/single-disk-bcachefs.nix b/2configs/fs/disko/single-disk-bcachefs.nix
new file mode 100644
index 000000000..cd73afd0d
--- /dev/null
+++ b/2configs/fs/disko/single-disk-bcachefs.nix
@@ -0,0 +1,38 @@
+{ disks ? [ "/dev/sda" ], ... }: {
+ disko.devices = {
+ disk = {
+ vdb = {
+ device = builtins.elemAt disks 0;
+ type = "disk";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ name = "ESP";
+ start = "1MiB";
+ end = "500MiB";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ }
+ {
+ name = "root";
+ start = "500MiB";
+ end = "100%";
+ part-type = "primary";
+ content = {
+ type = "filesystem";
+ format = "bcachefs";
+ mountpoint = "/";
+ };
+ }
+ ];
+ };
+ };
+ };
+ };
+}