summaryrefslogtreecommitdiffstats
path: root/2configs/binary-cache/server.nix
diff options
context:
space:
mode:
Diffstat (limited to '2configs/binary-cache/server.nix')
-rw-r--r--2configs/binary-cache/server.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/2configs/binary-cache/server.nix b/2configs/binary-cache/server.nix
index c1ae16e29..f8355bb95 100644
--- a/2configs/binary-cache/server.nix
+++ b/2configs/binary-cache/server.nix
@@ -1,12 +1,13 @@
{ config, lib, pkgs, ...}:
{
+ sops.secrets."nix-serve.key" = {};
# generate private key with:
# nix-store --generate-binary-cache-key gum nix-serve.key nix-serve.pub
services.nix-serve = {
enable = true;
port = 5001;
- secretKeyFile = toString <secrets> + "/nix-serve.key";
+ secretKeyFile = config.sops.secrets."nix-serve.key".path;
};
services.nginx = {