summaryrefslogtreecommitdiffstats
path: root/1systems/x/x13/amdgpu.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/x/x13/amdgpu.nix')
-rw-r--r--1systems/x/x13/amdgpu.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/1systems/x/x13/amdgpu.nix b/1systems/x/x13/amdgpu.nix
new file mode 100644
index 000000000..a6e4286bd
--- /dev/null
+++ b/1systems/x/x13/amdgpu.nix
@@ -0,0 +1,13 @@
+{
+ services.xserver.videoDrivers = [ "amdgpu" ];
+ boot.initrd.kernelModules = [ "amdgpu" ];
+ hardware.opengl.driSupport = true;
+ hardware.opengl.extraPackages = [ pkgs.amdvlk pkgs.rocm-opencl-icd pkgs.rocm-opencl-runtime ];
+ # For 32 bit applications
+ hardware.opengl.driSupport32Bit = true;
+ hardware.opengl.extraPackages32 = with pkgs; [ driversi686Linux.amdvlk ];
+ # is required for amd graphics support ( xorg wont boot otherwise )
+ users.groups.video = {};
+ users.groups.render = {};
+ users.users.makefu.extraGroups = [ "video" "render" ];
+}