summaryrefslogtreecommitdiffstats
path: root/1systems/tsp/config.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/tsp/config.nix')
-rw-r--r--1systems/tsp/config.nix52
1 files changed, 21 insertions, 31 deletions
diff --git a/1systems/tsp/config.nix b/1systems/tsp/config.nix
index 9586578d3..587d5f83d 100644
--- a/1systems/tsp/config.nix
+++ b/1systems/tsp/config.nix
@@ -1,45 +1,35 @@
-#
-#
-#
-{ config, pkgs, lib, ... }:
+{ config, pkgs, lib, self, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware.nix
- <stockholm/makefu>
- <stockholm/makefu/2configs/nur.nix>
- <stockholm/makefu/2configs/home-manager>
- <stockholm/makefu/2configs/main-laptop.nix>
- <stockholm/makefu/2configs/editor/neovim>
- <stockholm/makefu/2configs/tools/core.nix>
- # <stockholm/makefu/2configs/tools/all.nix>
- <stockholm/makefu/2configs/fs/single-partition-ext4.nix>
+ ../../2configs/default.nix
+ # (self + "/2configs/nur.nix")
+
+ # (self + "/2configs/nur.nix")
+ (self + "/2configs/home-manager")
+ (self + "/2configs/main-laptop.nix")
+ (self + "/2configs/editor/neovim")
+ (self + "/2configs/tools/core.nix")
+ # (self + "/2configs/tools/all.nix")
+ (self + "/2configs/fs/disko/single-disk-bcachefs.nix")
# hardware specifics are in here
- <stockholm/makefu/2configs/hw/bluetooth.nix>
- <stockholm/makefu/2configs/hw/network-manager.nix>
+ (self + "/2configs/hw/bluetooth.nix")
+ (self + "/2configs/hw/network-manager.nix")
- # <stockholm/makefu/2configs/rad1o.nix>
+ # (self + "/2configs/rad1o.nix")
- <stockholm/makefu/2configs/zsh-user.nix>
- <stockholm/makefu/2configs/home-manager>
- <stockholm/makefu/2configs/home-manager/desktop.nix>
- <stockholm/makefu/2configs/home-manager/cli.nix>
- <stockholm/makefu/2configs/tinc/retiolum.nix>
+ (self + "/2configs/zsh-user.nix")
+ (self + "/2configs/home-manager")
+ (self + "/2configs/home-manager/desktop.nix")
+ (self + "/2configs/home-manager/cli.nix")
- <stockholm/makefu/2configs/sshd-totp.nix>
- {
- programs.adb.enable = true;
- }
+ # still broken
+ #(self + "/2configs/tinc/retiolum.nix")
+ # (self + "/2configs/sshd-totp.nix")
];
- krebs.build.host = config.krebs.hosts.tsp;
- boot.loader.grub.device = "/dev/sda";
-
- networking.firewall.allowedTCPPorts = [
- 25
- ];
- hardware.enableRedistributableFirmware = true;
nixpkgs.config.allowUnfree = true;
}