summaryrefslogtreecommitdiffstats
path: root/1systems/lass/mors.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/lass/mors.nix')
-rw-r--r--1systems/lass/mors.nix48
1 files changed, 12 insertions, 36 deletions
diff --git a/1systems/lass/mors.nix b/1systems/lass/mors.nix
index 940dc4fdb..8cda1eac3 100644
--- a/1systems/lass/mors.nix
+++ b/1systems/lass/mors.nix
@@ -8,7 +8,6 @@
../../2configs/lass/browsers.nix
../../2configs/lass/games.nix
../../2configs/lass/pass.nix
- ../../2configs/lass/vim.nix
../../2configs/lass/virtualbox.nix
../../2configs/lass/elster.nix
../../2configs/lass/urxvt.nix
@@ -18,29 +17,13 @@
../../2configs/lass/binary-caches.nix
../../2configs/lass/ircd.nix
../../2configs/lass/chromium-patched.nix
- ../../2configs/lass/git-repos.nix
+ ../../2configs/lass/new-repos.nix
../../2configs/tv/synaptics.nix
- ../../2configs/tv/exim-retiolum.nix
- {
- imports = [ ../../3modules/tv/retiolum.nix ];
- tv.retiolum = {
- enable = true;
- hosts = ../../Zhosts;
- connectTo = [
- "fastpoke"
- "gum"
- "pigstarter"
- ];
- };
- }
- {
- imports = [ ../../3modules/tv/identity.nix ];
- tv.identity = {
- enable = true;
- };
- }
+ ../../2configs/lass/retiolum.nix
];
+ krebs.build.host = config.krebs.hosts.mors;
+
networking.hostName = "mors";
networking.wireless.enable = true;
@@ -168,21 +151,6 @@
'';
};
- users.extraUsers = {
- #main user
- mainUser = {
- uid = 1337;
- name = "lass";
- #isNormalUser = true;
- group = "users";
- createHome = true;
- home = "/home/lass";
- useDefaultShell = true;
- isSystemUser = false;
- extraGroups = [ "wheel" "audio" ];
- };
- };
-
environment.systemPackages = with pkgs; [
];
@@ -217,4 +185,12 @@
services.mongodb = {
enable = true;
};
+
+ lass.iptables = {
+ tables = {
+ filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 8000"; target = "ACCEPT"; precedence = 9001; }
+ ];
+ };
+ };
}