summaryrefslogtreecommitdiffstats
path: root/tv/configs/w110er.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 15:29:59 +0200
commitb5d5b75d7d6dcc42f69418e6a454a64502fa6aee (patch)
tree3e3a83c1252e8600b580f858b55e05591212e05a /tv/configs/w110er.nix
parent6167afb8b5f5e06a51745b71a47b6b0339aa0e99 (diff)
parent03e03a7cbda232d1e8581231aefe632072665194 (diff)
Merge branch 'tv' into master
Diffstat (limited to 'tv/configs/w110er.nix')
-rw-r--r--tv/configs/w110er.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/tv/configs/w110er.nix b/tv/configs/w110er.nix
new file mode 100644
index 000000000..96ee8c75b
--- /dev/null
+++ b/tv/configs/w110er.nix
@@ -0,0 +1,42 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ../configs/smartd.nix
+ ];
+
+ boot.extraModprobeConfig = ''
+ options kvm_intel nested=1
+ '';
+
+ boot.initrd.availableKernelModules = [ "ahci" ];
+ boot.kernelModules = [ "kvm-intel" ];
+
+ boot.loader.gummiboot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.wireless.enable = true;
+
+ nix = {
+ buildCores = 4;
+ maxJobs = 4;
+ daemonIONiceLevel = 1;
+ daemonNiceLevel = 1;
+ };
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ system.activationScripts.powertopTunables = ''
+ echo 1 > /sys/module/snd_hda_intel/parameters/power_save
+ echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
+ (cd /sys/bus/pci/devices
+ for i in *; do
+ echo auto > $i/power/control # defaults to 'on'
+ done)
+ '';
+}