summaryrefslogtreecommitdiffstats
path: root/tv/2configs/test.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-08-29 00:19:52 +0200
committertv <tv@shackspace.de>2015-08-29 00:20:58 +0200
commit09257f97823e9a57cda749c2d5a69b18ef484cec (patch)
treea92544b66b1784a05118a7dad4076f3b4013de23 /tv/2configs/test.nix
parent81eaf7a9e7b083c169828590d0d848cf933b32e0 (diff)
tv: use only pkgs
Diffstat (limited to 'tv/2configs/test.nix')
-rw-r--r--tv/2configs/test.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/tv/2configs/test.nix b/tv/2configs/test.nix
index fa556ec78..409b4e9b4 100644
--- a/tv/2configs/test.nix
+++ b/tv/2configs/test.nix
@@ -3,8 +3,6 @@
with import ../4lib { inherit lib pkgs; };
let
- tvpkgs = import ../5pkgs { inherit lib pkgs; };
-
out = {
environment.systemPackages = [
su-test
@@ -17,12 +15,12 @@ let
};
};
- su-test = tvpkgs.execveBin "su-test" rec {
+ su-test = pkgs.execveBin "su-test" rec {
filename = "/var/setuid-wrappers/sudo";
argv = ["sudo" "-u" "test" "-i"];
};
- test-shell = tvpkgs.execve "test-shell" rec {
+ test-shell = pkgs.execve "test-shell" rec {
filename = "${pkgs.bash}/bin/bash";
argv = ["sh" "--noprofile" "-l"];
envp.ENV = pkgs.writeText "test-env" ''
[cgit] Unable to lock slot /tmp/cgit/c8100000.lock: No such file or directory (2)