summaryrefslogtreecommitdiffstats
path: root/source.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-17 22:48:32 +0200
committermakefu <github@syntax-fehler.de>2017-07-17 22:48:32 +0200
commite2dacab501983da8a7b78ac348bfa1b5e6f08911 (patch)
tree511d49d1befa96d5bfe98cde302bf927c3632672 /source.nix
parent970469c10a7451cfede8c64b8406132f25019265 (diff)
ma sources: refactor redundant musnix in [vw]bob, studio
Diffstat (limited to 'source.nix')
-rw-r--r--source.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/source.nix b/source.nix
index 02ec2c177..ec86e7f77 100644
--- a/source.nix
+++ b/source.nix
@@ -1,10 +1,17 @@
with import <stockholm/lib>;
-host@{ name, secure ? false, override ? {}, full ? false, torrent ? false }: let
+host@{ name,
+ override ? {},
+ secure ? false,
+ full ? false,
+ torrent ? false,
+ musnix ? false
+}:
+let
builder = if getEnv "dummy_secrets" == "true"
then "buildbot"
else "makefu";
_file = <stockholm> + "/makefu/1systems/${name}/source.nix";
- ref = "0751450"; # unstable @ 2017-07-16 + graceful requests2 (a772c3aa)
+ ref = "74b40c3"; # unstable @ 2017-07-16 + graceful requests2 (a772c3aa) + libpurple bitlbee
in
evalSource (toString _file) [
@@ -32,6 +39,12 @@ in
stockholm.file = toString <stockholm>;
}
+ (mkIf ( musnix ) {
+ musnix.git = {
+ url = https://github.com/musnix/musnix.git;
+ ref = "d8b989f";
+ };
+ })
(mkIf ( torrent ) {
torrent-secrets.file = getAttr builder {
buildbot = toString <stockholm/makefu/6tests/data/secrets>;
[cgit] Unable to lock slot /tmp/cgit/70300000.lock: No such file or directory (2)