summaryrefslogtreecommitdiffstats
path: root/modules/tv/git/cgit.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-22 19:19:32 +0200
committertv <tv@shackspace.de>2015-06-22 19:19:32 +0200
commitff7178be0090f31e12c65d6158c558bf1d9d7f14 (patch)
treeca44202474824f9ad9f7f8ad6c34a2ec030bad32 /modules/tv/git/cgit.nix
parent964855f30bcb36869f24cb8474b9a0c44f58a736 (diff)
tv git: split module into options and config
Diffstat (limited to 'modules/tv/git/cgit.nix')
-rw-r--r--modules/tv/git/cgit.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/modules/tv/git/cgit.nix b/modules/tv/git/cgit.nix
index fd87b9081..826ee7f27 100644
--- a/modules/tv/git/cgit.nix
+++ b/modules/tv/git/cgit.nix
@@ -1,23 +1,15 @@
-{ config, lib, pkgs, ... }:
+{ cfg, config, lib, pkgs, ... }:
let
inherit (builtins) attrValues filter getAttr;
inherit (lib) concatMapStringsSep mkIf optionalString;
- cfg = config.services.git;
-
location = lib.nameValuePair; # TODO this is also in modules/wu/default.nix
isPublicRepo = getAttr "public"; # TODO this is also in ./default.nix
in
{
- imports = [
- ../../tv/nginx
- ];
-
- config = mkIf cfg.cgit {
-
users.extraUsers = lib.singleton {
name = "fcgiwrap";
uid = 2851179180; # genid fcgiwrap
@@ -93,5 +85,4 @@ in
'')
];
};
- };
}