summaryrefslogtreecommitdiffstats
path: root/modules/nginx.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-04-08 01:07:01 +0200
committertv <tv@shackspace.de>2015-05-19 23:16:56 +0200
commitcd6374e641420ade3603f0fd23fe9afac5c443bc (patch)
tree14dd49072264f70f32d826fadc3489a7b101b62c /modules/nginx.nix
parent6e70d8fc47f0725a63dc92c1c43d2b1831c7c4ef (diff)
I Like To Move It
Diffstat (limited to 'modules/nginx.nix')
-rw-r--r--modules/nginx.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/nginx.nix b/modules/nginx.nix
deleted file mode 100644
index 8b420613b..000000000
--- a/modules/nginx.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- services.nginx =
- let
- name = config.networking.hostName;
- qname = "${name}.retiolum";
- in
- {
- enable = true;
- httpConfig = ''
- sendfile on;
- server {
- listen 80;
- server_name ${name} ${qname} localhost;
- root /srv/http/${name};
- location ~ ^/~(.+?)(/.*)?$ {
- alias /home/$1/public_html$2;
- }
- }
- types {
- text/css css;
- text/html html;
- image/svg+xml svg;
- }
- default_type text/html;
- charset utf-8;
- '';
- };
-}