summaryrefslogtreecommitdiffstats
path: root/miefda/2configs/tlp.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-08 03:23:28 +0100
committertv <tv@krebsco.de>2016-02-08 03:35:29 +0100
commit8e93530796982db49ddeb06201d2f5bb57d51ccc (patch)
tree0c2982f48ca668cc034f4c10485c6a5b0e841d81 /miefda/2configs/tlp.nix
parent7a9f130c1230faf9662000dbd9ba8f06170bf254 (diff)
parent5856d240888e89dbed141087c9580026f52dff59 (diff)
Merge remote-tracking branch 'cloudkrebs/master'
Diffstat (limited to 'miefda/2configs/tlp.nix')
-rw-r--r--miefda/2configs/tlp.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/miefda/2configs/tlp.nix b/miefda/2configs/tlp.nix
new file mode 100644
index 000000000..0e1bb0d6b
--- /dev/null
+++ b/miefda/2configs/tlp.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+
+ hardware.cpu.intel.updateMicrocode = true;
+
+ zramSwap.enable = true;
+ zramSwap.numDevices = 2;
+
+ hardware.trackpoint = {
+ enable = true;
+ sensitivity = 220;
+ speed = 220;
+ emulateWheel = true;
+ };
+
+
+ services.tlp.enable = true;
+ services.tlp.extraConfig = ''
+ START_CHARGE_THRESH_BAT0=80
+ '';
+}