summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/darth.nix
diff options
context:
space:
mode:
authormakefu <makefu@nixos.dev>2016-05-02 16:08:30 +0200
committermakefu <makefu@nixos.dev>2016-05-02 16:08:30 +0200
commit64aa4f6912fb7425d8063e5d143f59c43fb31b8f (patch)
tree07fe7c386d32bd5e1375a7d01f623cd357a1d09d /makefu/1systems/darth.nix
parent3f77b6c89f4a3a28d62e9117712481489ac56fa1 (diff)
parent6f4bc4b34c3cbac56f6a23740dca566980823990 (diff)
Merge branch 'master' of gum:stockholm
Diffstat (limited to 'makefu/1systems/darth.nix')
-rw-r--r--makefu/1systems/darth.nix20
1 files changed, 16 insertions, 4 deletions
diff --git a/makefu/1systems/darth.nix b/makefu/1systems/darth.nix
index ad3ac4f22..2f2358ddc 100644
--- a/makefu/1systems/darth.nix
+++ b/makefu/1systems/darth.nix
@@ -10,15 +10,27 @@ let
allDisks = [ rootDisk auxDisk ];
in {
imports = [
- ../.
- ../2configs/fs/single-partition-ext4.nix
- ../2configs/zsh-user.nix
- ../2configs/smart-monitor.nix
+ ../.
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/zsh-user.nix
+ ../2configs/smart-monitor.nix
+ ../2configs/exim-retiolum.nix
+ ../2configs/virtualization.nix
];
+ networking.firewall.allowedUDPPorts = [ 80 655 67 ];
+ networking.firewall.allowedTCPPorts = [ 80 655 ];
+ networking.firewall.checkReversePath = false;
+ #networking.firewall.enable = false;
# virtualisation.nova.enableSingleNode = true;
krebs.retiolum.enable = true;
+ boot.kernelModules = [ "coretemp" "f71882fg" ];
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ networking.wireless.enable = true;
+
# TODO smartd omo darth gum all-in-one
services.smartd.devices = builtins.map (x: { device = x; }) allDisks;
zramSwap.enable = true;