summaryrefslogtreecommitdiffstats
path: root/lass/2configs/otp-ssh.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-07-21 09:11:08 +0200
committermakefu <github@syntax-fehler.de>2017-07-21 09:11:08 +0200
commit77ea3dc79ba5c82663977755d673d2c8f8fdd0b1 (patch)
treeb030977f43c10cd13968836aff6f91dacfb849b2 /lass/2configs/otp-ssh.nix
parent0cce2f9d14766dc29674c098fe84aaca0adc7876 (diff)
parent8bfcf85531c4b8455c301504ccd74f95487e86d0 (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'lass/2configs/otp-ssh.nix')
-rw-r--r--lass/2configs/otp-ssh.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/lass/2configs/otp-ssh.nix b/lass/2configs/otp-ssh.nix
new file mode 100644
index 000000000..f9984e245
--- /dev/null
+++ b/lass/2configs/otp-ssh.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+# Enables second factor for ssh password login
+
+## Usage:
+# gen-oath-safe <username> totp
+## scan the qrcode with google authenticator (or FreeOTP)
+## copy last line into secrets/<host>/users.oath (chmod 700)
+{
+ security.pam.oath = {
+ # enabling it will make it a requisite of `all` services
+ # enable = true;
+ digits = 6;
+ # TODO assert existing
+ usersFile = (toString <secrets>) + "/users.oath";
+ };
+ # I want TFA only active for sshd with password-auth
+ security.pam.services.sshd.oathAuth = true;
+}