summaryrefslogtreecommitdiffstats
path: root/lass/1systems/test-arch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
committermakefu <github@syntax-fehler.de>2015-10-23 15:38:01 +0200
commita1d05482e5527d32baef9d9343b900dee8d46694 (patch)
tree2de3ac509481799f6188620987cdf1678ea675a5 /lass/1systems/test-arch.nix
parent709ebf6bbcc2e0d4644ed35cd42db47c4f2e78c5 (diff)
parent93dcfe5ad61903f90f422d9d6c97e499b240aa86 (diff)
Merge remote-tracking branch 'cloudkrebs/master'
Diffstat (limited to 'lass/1systems/test-arch.nix')
-rw-r--r--lass/1systems/test-arch.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/lass/1systems/test-arch.nix b/lass/1systems/test-arch.nix
new file mode 100644
index 000000000..0ab9da2f3
--- /dev/null
+++ b/lass/1systems/test-arch.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import ../4lib { inherit pkgs lib; }) getDefaultGateway;
+ inherit (lib) head;
+
+in {
+ imports = [
+ ../2configs/base.nix
+ {
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "vmw_pvscsi"
+ ];
+
+ fileSystems."/" = {
+ device = "/dev/sda1";
+ };
+ }
+ {
+ networking.dhcpcd.allowInterfaces = [
+ "enp*"
+ ];
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-arch;
+}