summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/urlwatch/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-06-20 16:05:27 +0200
committerlassulus <lass@lassul.us>2017-06-20 16:05:27 +0200
commitf0bcc6e1f147726cbbf8c3d8a9da503886d2321d (patch)
treebf8e0eabe03a8dcf9201c580ab1f4ecc4660b8b4 /krebs/5pkgs/simple/urlwatch/default.nix
parentbda14221cf46003ecf76756a5db7422c70737c85 (diff)
parent57c6b890f9088bb333eeab215ecfeca9d09ce3ef (diff)
Merge remote-tracking branch 'ni/master' into HEAD
Diffstat (limited to 'krebs/5pkgs/simple/urlwatch/default.nix')
-rw-r--r--krebs/5pkgs/simple/urlwatch/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/krebs/5pkgs/simple/urlwatch/default.nix b/krebs/5pkgs/simple/urlwatch/default.nix
index 7ffbd8870..509555669 100644
--- a/krebs/5pkgs/simple/urlwatch/default.nix
+++ b/krebs/5pkgs/simple/urlwatch/default.nix
@@ -1,16 +1,17 @@
{ stdenv, fetchurl, python3Packages }:
python3Packages.buildPythonPackage rec {
- name = "urlwatch-2.5";
+ name = "urlwatch-${meta.version}";
src = fetchurl {
- url = "https://thp.io/2008/urlwatch/${name}.tar.gz";
- sha256 = "0qirpymdmpsx0klmhbx3icmiwpm6fx4wjma646gl9m90pifs8430";
+ url = "https://github.com/thp/urlwatch/archive/${meta.version}.tar.gz";
+ sha256 = "09bn31gn03swi7yr3s1ql8x07hx96gap1ka77kk44kk0lvfxn55b";
};
propagatedBuildInputs = with python3Packages; [
keyring
minidb
+ pycodestyle
pyyaml
requests2
];
@@ -20,5 +21,6 @@ python3Packages.buildPythonPackage rec {
homepage = https://thp.io/2008/urlwatch/;
license = stdenv.lib.licenses.bsd3;
maintainers = [ stdenv.lib.maintainers.tv ];
+ version = "2.6";
};
}
[cgit] Unable to lock slot /tmp/cgit/3a200000.lock: No such file or directory (2)