summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/posix-array/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-11 21:31:15 +0100
committermakefu <github@syntax-fehler.de>2016-02-11 21:31:15 +0100
commit014cbb7598c5d45cfc4cc7e1ec81c92e000eabfb (patch)
treefab0e894948010cd73be18ad2c68cd4750bd2419 /krebs/5pkgs/posix-array/default.nix
parent8ecdb889dd3081ba29c6ea7eb35f60b30420d201 (diff)
parent7b3b839cc7a2af73dee9858e6ebcc7be831eb481 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'krebs/5pkgs/posix-array/default.nix')
-rw-r--r--krebs/5pkgs/posix-array/default.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/krebs/5pkgs/posix-array/default.nix b/krebs/5pkgs/posix-array/default.nix
index 456a3cc11..cfcdb29a7 100644
--- a/krebs/5pkgs/posix-array/default.nix
+++ b/krebs/5pkgs/posix-array/default.nix
@@ -1,7 +1,7 @@
-{ stdenv, fetchgit, ... }:
+{ fetchgit, lib, stdenv, ... }:
-with stdenv; stdenv.mkDerivation rec {
- name = "posix-array";
+stdenv.mkDerivation rec {
+ name = "posix-array-${version}";
version = "1.0.0";
src = fetchgit {
@@ -16,16 +16,15 @@ with stdenv; stdenv.mkDerivation rec {
];
installPhase = ''
- mkdir -p "$out/bin"
+ mkdir -p $out/bin
cp -a ./array $out/bin
- rm *
'';
meta = {
- description = "Posix-compliant array implementation";
+ description = "POSIX-compliant array implementation";
url = https://github.com/makefu/array;
- license = licenses.wtfpl;
- platforms = platforms.unix;
- maintainers = with maintainers; [ makefu ];
+ license = lib.licenses.wtfpl;
+ platforms = lib.platforms.unix;
+ maintainers = with lib.maintainers; [ makefu ];
};
}