summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/nix-diff/nixos-system.patch
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-13 15:19:19 +0100
committertv <tv@krebsco.de>2017-12-13 15:19:19 +0100
commitf3f61c85fd66f496bbaa850a6a01db2a79914ae6 (patch)
treeab6e1bfa173641c503641a9077703b6cdf61d9c7 /krebs/5pkgs/haskell/nix-diff/nixos-system.patch
parent2f3f0bbb315133e777a4b1f2e70bb7d38266eb79 (diff)
haskellPackages.nix-diff: 1.0.0 -> 1.0.0-krebs1
Diffstat (limited to 'krebs/5pkgs/haskell/nix-diff/nixos-system.patch')
-rw-r--r--krebs/5pkgs/haskell/nix-diff/nixos-system.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/nix-diff/nixos-system.patch b/krebs/5pkgs/haskell/nix-diff/nixos-system.patch
new file mode 100644
index 000000000..03e186aa9
--- /dev/null
+++ b/krebs/5pkgs/haskell/nix-diff/nixos-system.patch
@@ -0,0 +1,18 @@
+diff --git a/src/Main.hs b/src/Main.hs
+index 959ab8e..d3b6077 100644
+--- a/src/Main.hs
++++ b/src/Main.hs
+@@ -95,7 +95,12 @@ pathToText path =
+ underneath `/nix/store`, but this is the overwhelmingly common use case
+ -}
+ derivationName :: FilePath -> Text
+-derivationName = Data.Text.dropEnd 4 . Data.Text.drop 44 . pathToText
++derivationName p =
++ if Data.Text.isPrefixOf "nixos-system" s
++ then "nixos-system"
++ else s
++ where
++ s = Data.Text.dropEnd 4 . Data.Text.drop 44 . pathToText $ p
+
+ -- | Group input derivations by their name
+ groupByName :: Map FilePath (Set Text) -> Map Text (Map FilePath (Set Text))
[cgit] Unable to lock slot /tmp/cgit/8a300000.lock: No such file or directory (2)